Process Simulate Collaborate issue resolved- Americas and Europe

Incident Report for Siemens Service Status

Resolved

The issue with Process Simulate Collaborate has been resolved.
Posted Mar 17, 2025 - 09:01 UTC

Investigating

We are currently having issues with Process Simulate Collaborate . Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Mar 17, 2025 - 08:43 UTC
This incident affected: Europe (Process Simulate Collaborate) and Americas (Process Simulate Collaborate).