Zel X is currently experiencing issues - America, Asia
Incident Report for Siemens Service Status
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 21:54 UTC
Update
We are still investigating an issue and engaging the resources needed to troubleshoot.

We will provide updates as we get them.
Posted Nov 21, 2022 - 21:42 UTC
Investigating
We are currently investigating an issue and engaging the resources needed to troubleshoot. We will provide updates as we get them.
Posted Nov 21, 2022 - 21:17 UTC
This incident affected: Asia (Zel X) and Americas (Zel X).