PartQuest Portal (ECAD) is currently experiencing issues - AP, US, EU

Incident Report for Siemens Service

Update

We are continuing to work on a fix for this issue.
Posted Sep 17, 2026 - 10:46 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 17, 2026 - 09:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 17, 2026 - 07:54 UTC

Identified

We are currently having issues with PartQuest Portal (ECAD). Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Sep 17, 2026 - 01:26 UTC

Investigating

We are currently having issues with PartQuest Portal (ECAD). Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Sep 17, 2026 - 01:20 UTC
This incident affects: Asia (PartQuest Portal), Europe (PartQuest Portal), and Americas (PartQuest Portal).