Teamcenter for Microsoft Teams issue resolved - Americas

Incident Report for Siemens Service

Resolved

The issue with Teamcenter for Microsoft Teams has been resolved.
Posted Mar 24, 2026 - 10:44 UTC

Investigating

We are currently having issues with Teamcenter for Microsoft Teams. Our development team is looking into the incident.

We’ll send an update when the issue is resolved.

Check updates: https://status.sw.siemens.com/
Posted Mar 24, 2026 - 10:36 UTC
This incident affected: Americas (Teamcenter for Microsoft Teams).