Hour Of Engineering - Middle School issue is resolved - Americas

Incident Report for Siemens Service Status

Resolved

This incident has been resolved.
Posted May 14, 2025 - 12:42 UTC

Investigating

We are currently having issues with Hour Of Engineering - Middle School. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted May 12, 2025 - 08:55 UTC
This incident affected: Americas (Hour Of Engineering - Middle School).