Siemens Xcelerator Admin Console issue resolved - Americas, Europe, Asia

Incident Report for Siemens Service Status

Resolved

The issue with Siemens Xcelerator Admin Console has been resolved.
Posted Mar 28, 2025 - 09:40 UTC

Investigating

We are currently having issues with Siemens Xcelerator Admin Console. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Mar 28, 2025 - 09:05 UTC
This incident affected: Asia (Siemens Xcelerator Admin Console), Europe (Siemens Xcelerator Admin Console), and Americas (Siemens Xcelerator Admin Console).