Informational Update: Access Issue with Some Web Applications on Latest Chrome Versions

Incident Report for Siemens Service Status

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 13:37 UTC

Monitoring

We are actively monitoring the situation and will share updates as soon as they are available.

Reference: https://support.google.com/chrome/a/thread/384022238/cors-issue-with-version-142-but-not-in-version-141?hl=en
Posted Nov 28, 2025 - 03:21 UTC

Update

We are continuing to investigate this issue.
Posted Nov 28, 2025 - 03:14 UTC

Investigating

What’s Happening?

Recent versions of Google Chrome (starting from version 142) introduced a change that may prevent some web applications, including the Siemens Xcelerator Admin Console, from loading correctly.

What You Can Do:

If you are experiencing issues, please use an earlier version of Chrome (before version 142) or switch to another browser (such as Microsoft Edge or Firefox) until Google provides a fix.

Thank you for your understanding.

Reference: https://support.google.com/chrome/a/thread/384022238/cors-issue-with-version-142-but-not-in-version-141?hl=en
Posted Nov 28, 2025 - 02:48 UTC
This incident affected: Americas (Siemens Xcelerator Admin Console).