Copilot Services issue resolved - Americas, Europe and Asia

Incident Report for Siemens Service

Resolved

The issue with Copilot has been resolved.
Posted Feb 23, 2026 - 23:32 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 22:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 23, 2026 - 20:36 UTC

Investigating

We are currently having issues with Copilot. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Feb 23, 2026 - 18:22 UTC
This incident affected: Americas (Designcenter X NX).