Zel X is currently experiencing issues - Americas, Asia, Europe
Incident Report for Siemens Service Status
Resolved
We have resolved the issue with Zel X. Thank you for your patience.
Posted Dec 12, 2024 - 16:16 UTC
Investigating
We are currently having issues with Zel X. Our development team is looking into the incident. Thank you for your patience as we work to resolve the incident.
We will send an update upon completion. For updates, please visit https://status.sw.siemens.com/
Posted Dec 12, 2024 - 15:39 UTC
This incident affected: Europe (Zel X), Asia (Zel X), and Americas (Zel X).