SimcenterX issue resolved - Americas, Europe, Asia

Incident Report for Siemens Service

Resolved

The issue with SimcenterX has been resolved.
Posted Apr 02, 2026 - 15:23 UTC

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 14:51 UTC

Investigating

We are currently having issues with SimcenterX . Our development team is looking into the incident.

We’ll send an update when the issue is resolved.

Check updates: https://status.sw.siemens.com/
Posted Apr 02, 2026 - 14:22 UTC
This incident affected: Asia (Simcenter X - HPC & remote desktop), Europe (Simcenter X - HPC & remote desktop), and Americas (Simcenter X - HPC & remote desktop).