Connect issue is resolved - Europe

Incident Report for Siemens Service

Resolved

The issue with Connect has been resolved.
Posted Mar 19, 2026 - 08:58 UTC

Identified

We are currently having issues with Connect. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Mar 19, 2026 - 05:53 UTC

Investigating

We are currently investigating this issue.
Posted Mar 18, 2026 - 22:34 UTC
This incident affected: Europe (Connect).