Mendix Cloudnot accessible: Middle School Home Landing Page [US] down

Incident Report for Siemens Service

Resolved

XCE is now accessible and operational: https://xce.mendixcloud.com/
Posted May 12, 2026 - 18:38 UTC

Monitoring

A fix has been implemented by Mendix and results are being monitored.
Posted May 12, 2026 - 18:14 UTC

Identified

Mendix Status Page: https://status.mendix.com/
Posted May 12, 2026 - 17:28 UTC

Investigating

Middle School Home Landing Page [US] is currently down.

Mendix Status Page: https://status.mendix.com/
Posted May 12, 2026 - 16:43 UTC
This incident affected: Americas (Hour Of Engineering - Middle School).