Connect issue resolved - Americas , Asia

Incident Report for Siemens Service Status

Resolved

The issue with Connect has been resolved.
Posted Mar 17, 2025 - 09:06 UTC

Investigating

We are currently having issues with Connect. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Mar 17, 2025 - 08:26 UTC
This incident affected: Asia (Connect) and Americas (Connect).