TCX Essentials and NXX will be under maintenance - Americas

Scheduled for May 24, 00:30 UTC  -  May 25, 14:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 09, 2025 - 05:35 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 09, 2025 - 05:26 UTC

Scheduled

We expect this to take about 38 hours . During this time you may experience downtime.

We will send an update upon completion. Check updates: https://status.sw.siemens.com/

Any issues? Contact Support Center (link to: https://support.sw.siemens.com/
Posted May 08, 2025 - 07:55 UTC
This scheduled maintenance affects: Americas (TcX Essentials).