Teamcenter Share issue resolved - Americas

Incident Report for Siemens Service

Resolved

The issue with Teamcenter Share has been resolved.
Posted Mar 16, 2026 - 15:01 UTC

Investigating

We are currently having issues with Teamcenter Share. Our development team is looking into the incident.

We’ll send an update when the issue is resolved.

Check updates: https://status.sw.siemens.com/
Posted Mar 16, 2026 - 13:27 UTC
This incident affected: Americas (Teamcenter Share).