Simcenter X issue is resolved - Americas, Europe, Asia

Incident Report for Siemens Service Status

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 12:59 UTC

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 10:34 UTC

Investigating

We are currently having issues with Simcenter X. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Mar 24, 2025 - 10:20 UTC
This incident affected: Asia (Simcenter X), Europe (Simcenter X), and Americas (Simcenter X).