PartQuest multiple products issue resolved - Americas, Europe, Asia

Incident Report for Siemens Service Status

Resolved

The issue with PartQuest has been resolved.
Posted Oct 14, 2025 - 10:07 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 13, 2025 - 20:41 UTC

Update

Work is in progress with an ETR of ≈14 hours to fulfill development, QA, and deployment.


We will provide the next update as soon as development work begins.
Posted Oct 13, 2025 - 20:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 13, 2025 - 17:51 UTC

Investigating

We are currently investigating this issue.
Posted Oct 13, 2025 - 16:30 UTC
This incident affected: Asia (PartQuest Portal, PartQuest Search), Europe (PartQuest Portal, Connect, PartQuest Search), and Americas (PartQuest Explore, PartQuest Portal, Connect, PartQuest Search).