TCX Essentials issue resolved - US

Incident Report for Siemens Service Status

Resolved

We have resolved the issue with TCX Essentials. Thank you for your patience.
Posted Mar 18, 2025 - 18:17 UTC

Identified

We are currently having issues with TCX Essentials. Our development team is looking into the incident. Thank you for your patience as we work to resolve the incident.
We will send an update upon completion. For updates, please visit https://status.sw.siemens.com/
Posted Mar 18, 2025 - 17:05 UTC
This incident affected: Americas (TcX Essentials).