PartQuest Search issues resolved - Asia, Europe, Americas

Incident Report for Siemens Service

Resolved

The issue with PartQuest Search has been resolved.
Posted Apr 07, 2026 - 13:48 UTC

Investigating

We are currently having issues with PartQuest Search. Our development team is looking into the incident.

We’ll send an update when the issue is resolved.

Check updates: https://status.sw.siemens.com/
Posted Apr 07, 2026 - 10:45 UTC
This incident affected: Asia (PartQuest Search), Europe (PartQuest Search), and Americas (PartQuest Search).