Simcenter X is currently experiencing issues - EU

Incident Report for Siemens Service Status

Resolved

This incident has been resolved. Thank you for your patience
Posted Feb 14, 2025 - 02:36 UTC

Investigating

We are currently having issues with Simcenter X. Our development team is looking into the incident. Thank you for your patience as we work to resolve the incident.
We will send an update upon completion. For updates, please visit https://status.sw.siemens.com/
Posted Feb 14, 2025 - 01:15 UTC
This incident affected: Europe (Simcenter X).