Teamcenter Share issue resolved - All Region

Incident Report for Siemens Service Status

Resolved

After the investigation, no issue was found with Teamcenter Share.

Teamcenter Share was fully operational during the reported time.
Posted Jul 09, 2025 - 01:10 UTC

Investigating

We are currently having issues with Teamcenter Share. Our development team is looking into the incident.

We’ll send an update when the issue is resolved. Check updates: https://status.sw.siemens.com/
Posted Jul 09, 2025 - 00:22 UTC
This incident affected: Americas (Teamcenter Share), Europe (Teamcenter Share), Asia (Teamcenter Share), and China (Teamcenter Share).